steve今天考我的题目,写诗写出来了,不过没法提交oj验证。
原题如下:
Dual Palindromes
Mario Cruz (Colombia) & Hugo Rickeboer (Argentina)
A number that reads the same from right to left as when read from left to right is called a palindrome. The number 12321 is a palindrome; the number 77778 is not. Of course, palindromes have neither leading nor trailing zeroes, so 0220 is not a palindrome.
The number 21 (base 10) is not palindrome in base 10, but the number 21 (base 10) is, in fact, a palindrome in base 2 (10101).
Write a program that reads two numbers (expressed in base 10):
N (1 <= N <= 15)
S (0 < S < 10000)
and then finds and prints (in base 10) the first N numbers strictly greater than S that are palindromic when written in two or more number bases (2 <= base <= 10).
Solutions to this problem do not require manipulating integers larger than the standard 32 bits.
PROGRAM NAME: dualpal
INPUT FORMAT
A single line with space separated integers N and S.
SAMPLE INPUT (file dualpal.in)
3 25
OUTPUT FORMAT
N lines, each with a base 10 number that is palindromic when expressed in at least two of the bases 2..10. The numbers should be listed in order from smallest to largest.
SAMPLE OUTPUT (file dualpal.out)
26
27
28
我的输入输出格式直接就不管了。自己的代码如下:
#include<iostream>
using namespace std;
void get_jinzhi(unsigned int num,unsigned int base,int *array,int& point)
{
unsigned int shang;
point=0;
while(base<=num)
{
shang=num/base;
array[point]=num % base;
num=shang;
++point;
}
array[point]=num;
}
bool decide(int* jinzhi,int point)
{
bool flag="true";
int j="0";
while(j<=point/2)
{
if (jinzhi[j]==jinzhi[point-j])
j++;
else
{
flag=false;
return flag;
}
}
return flag;
}
int main(void)
{
int jinzhi[21]={0};
int point="0";
unsigned int S="0",N=0;
unsigned int rt_tms,number,base;
cin>>N>>S;
rt_tms=0;
number=S;
while (rt_tms<N)
{
++number;
for (base=2;base<=10;++base)
{
get_jinzhi(number,base,jinzhi,point);
if (decide(jinzhi,point))
{
cout<<number<<endl;
++rt_tms;
break;
}
}
}
return 0;
}
用户377235 2013-6-6 19:36