如何解决IAR开发STM32 ARM版本不兼容的问题
eeskill 2023-11-28


对于V4 和V5不兼容的解决方法很多了,最近用V6 版开发,结果同事用V5.3版 ,我调通之后代码给他,结果他那边显示错误,配置资料失效了,查看是版本不同导致的。懒得转换,但是没办法还是得转换,只好新建一个空的 IAR 5.3版的工程,保证存放文件的目录结构和之前的目录结构相同,然后在工程中点击菜单栏的 Project 选项 ——Import File List...



然后开始导入新版本的工程文件信息



选择之前的新版本的 *.ewp 文件 导入,立刻之前的文件列表就出现在旧版本的界面左侧。还差3步完成:


1 在项目的Option--General Option 选择器件类型


2 在项目的Option--C/C++ Compilier --Preprocessor里复制之前新版本中的搜索路径



3.在下面的Define Symbole 里粘贴上新版本中对应的内容



声明: 本文转载自其它媒体或授权刊载,目的在于信息传递,并不代表本站赞同其观点和对其真实性负责,如有新闻稿件和图片作品的内容、版权以及其它问题的,请联系我们及时删除。(联系我们,邮箱:evan.li@aspencore.com )
0
评论
  • 对话周祖成教授 - 清华大学与西门子EDA的合作之旅


  • 相关技术文库
  • 单片机
  • 嵌入式
  • MCU
  • STM
下载排行榜
更多
评测报告
更多
广告